summaryrefslogtreecommitdiffstats
path: root/examples/widgets/itemviews/simpledommodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/itemviews/simpledommodel/CMakeLists.txt')
-rw-r--r--examples/widgets/itemviews/simpledommodel/CMakeLists.txt42
1 files changed, 27 insertions, 15 deletions
diff --git a/examples/widgets/itemviews/simpledommodel/CMakeLists.txt b/examples/widgets/itemviews/simpledommodel/CMakeLists.txt
index 2514287049..4a1812d96d 100644
--- a/examples/widgets/itemviews/simpledommodel/CMakeLists.txt
+++ b/examples/widgets/itemviews/simpledommodel/CMakeLists.txt
@@ -1,19 +1,31 @@
# Generated from simpledommodel.pro.
-#####################################################################
-## simpledommodel Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(simpledommodel LANGUAGES CXX)
-add_qt_executable(simpledommodel
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/simpledommodel"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/simpledommodel"
- SOURCES
- domitem.cpp domitem.h
- dommodel.cpp dommodel.h
- main.cpp
- mainwindow.cpp mainwindow.h
- LIBRARIES
- Qt::Xml
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Xml)
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(simpledommodel WIN32 MACOSX_BUNDLE
+ domitem.cpp domitem.h
+ dommodel.cpp dommodel.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+)
+target_link_libraries(simpledommodel PUBLIC
+ Qt::Widgets
+ Qt::Xml
+)
+
+install(TARGETS simpledommodel
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)