summaryrefslogtreecommitdiffstats
path: root/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/mainwindows/mainwindow/CMakeLists.txt')
-rw-r--r--examples/widgets/mainwindows/mainwindow/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/examples/widgets/mainwindows/mainwindow/CMakeLists.txt b/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
new file mode 100644
index 0000000000..df1d9b6355
--- /dev/null
+++ b/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Generated from mainwindow.pro.
+
+#####################################################################
+## mainwindow Binary:
+#####################################################################
+
+add_qt_executable(mainwindow
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/mainwindows/mainwindow"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/mainwindows/mainwindow"
+ SOURCES
+ colorswatch.cpp colorswatch.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ toolbar.cpp toolbar.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(mainwindow "mainwindow" PREFIX "/res" FILES
+ qt.png
+ titlebarCenter.png
+ titlebarLeft.png
+ titlebarRight.png)
+
+
+#### Keys ignored in scope 1:.:mainwindow.pro:<NONE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:mainwindow.pro:build_all AND NOT build_pass:
+# CONFIG = "-build_all" "release"