summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/affine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/affine/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/affine/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/widgets/painting/affine/CMakeLists.txt b/examples/widgets/painting/affine/CMakeLists.txt
new file mode 100644
index 0000000000..cda43296dd
--- /dev/null
+++ b/examples/widgets/painting/affine/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from affine.pro.
+
+#####################################################################
+## affine Binary:
+#####################################################################
+
+add_qt_executable(affine
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/affine"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/affine"
+ SOURCES
+ main.cpp
+ xform.cpp xform.h
+ # INCLUDE_DIRECTORIES ../shared # special case
+ LIBRARIES # special case
+ painting_shared
+)
+
+# Resources:
+add_qt_resource(affine "affine" PREFIX "/res/affine" FILES
+ bg1.jpg
+ xform.cpp
+ xform.html)