summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/affine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/affine/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/affine/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/examples/widgets/painting/affine/CMakeLists.txt b/examples/widgets/painting/affine/CMakeLists.txt
index dbc38202c2..88792be8f0 100644
--- a/examples/widgets/painting/affine/CMakeLists.txt
+++ b/examples/widgets/painting/affine/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from affine.pro.
-
cmake_minimum_required(VERSION 3.16)
project(affine LANGUAGES CXX)
@@ -18,12 +16,10 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/painting/affine")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
qt_add_executable(affine
- # special case begin
# remove files from ../shared
#../shared/arthurstyle.cpp ../shared/arthurstyle.h
#../shared/arthurwidgets.cpp ../shared/arthurwidgets.h
#../shared/hoverpoints.cpp ../shared/hoverpoints.h
- # special case end
main.cpp
xform.cpp xform.h
)
@@ -35,17 +31,15 @@ target_include_directories(affine PUBLIC
../shared
)
-# special case begin
if(NOT TARGET painting_shared::painting_shared)
include(../shared/use_lib.cmake)
endif()
-# special case end
target_link_libraries(affine PUBLIC
Qt::Core
Qt::Gui
Qt::Widgets
- painting_shared::painting_shared # special case
+ painting_shared::painting_shared
)
@@ -109,7 +103,6 @@ qt_add_resources(affine "affine"
${affine_resource_files}
)
-# special case begin
# remove files from ../shared
#if(QT_FEATURE_opengl)
#target_sources(affine PUBLIC
@@ -120,7 +113,6 @@ qt_add_resources(affine "affine"
#Qt::OpenGL
#)
#endif()
-# special case end
install(TARGETS affine
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"