summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/deform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/deform/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/deform/CMakeLists.txt75
1 files changed, 24 insertions, 51 deletions
diff --git a/examples/widgets/painting/deform/CMakeLists.txt b/examples/widgets/painting/deform/CMakeLists.txt
index 6ab43cc371..1038df03ad 100644
--- a/examples/widgets/painting/deform/CMakeLists.txt
+++ b/examples/widgets/painting/deform/CMakeLists.txt
@@ -1,56 +1,34 @@
-# Generated from deform.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(deform LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/painting/deform")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
+qt_standard_project_setup()
qt_add_executable(deform
- # special case begin
- # remove files from ../shared
- #../shared/arthurstyle.cpp ../shared/arthurstyle.h
- #../shared/arthurwidgets.cpp ../shared/arthurwidgets.h
- #../shared/hoverpoints.cpp ../shared/hoverpoints.h
- # special case end
main.cpp
pathdeform.cpp pathdeform.h
)
+
set_target_properties(deform PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_include_directories(deform PUBLIC
- ../shared
-)
-# special case begin
if(NOT TARGET painting_shared::painting_shared)
include(../shared/use_lib.cmake)
endif()
-# special case end
-target_link_libraries(deform PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
- painting_shared::painting_shared # special case
+target_link_libraries(deform PRIVATE
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Widgets
+ painting_shared::painting_shared
)
-
# Resources:
set(shared_resource_files
"../shared/images/button_normal_cap_left.png"
@@ -90,7 +68,7 @@ set(shared_resource_files
"../shared/images/title_stretch.png"
)
-qt6_add_resources(deform "shared"
+qt_add_resources(deform "shared"
PREFIX
"/res"
BASE
@@ -98,33 +76,28 @@ qt6_add_resources(deform "shared"
FILES
${shared_resource_files}
)
+
set(deform_resource_files
"pathdeform.cpp"
"pathdeform.html"
)
-qt6_add_resources(deform "deform"
+qt_add_resources(deform "deform"
PREFIX
"/res/deform"
FILES
${deform_resource_files}
)
-# special case begin
-# remove files from ../shared
-#if(QT_FEATURE_opengl)
- #target_sources(affine PUBLIC
- #../shared/fbopaintdevice.cpp ../shared/fbopaintdevice.h
- #)
-
- #target_link_libraries(affine PUBLIC
- #Qt::OpenGL
- #)
-#endif()
-# special case end
-
install(TARGETS deform
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION .
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)
+
+qt_generate_deploy_app_script(
+ TARGET deform
+ OUTPUT_SCRIPT deploy_script
+ NO_UNSUPPORTED_PLATFORM_ERROR
)
+install(SCRIPT ${deploy_script})