summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/deform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/deform/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/deform/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/widgets/painting/deform/CMakeLists.txt b/examples/widgets/painting/deform/CMakeLists.txt
new file mode 100644
index 0000000000..67622da25d
--- /dev/null
+++ b/examples/widgets/painting/deform/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from deform.pro.
+
+#####################################################################
+## deform Binary:
+#####################################################################
+
+add_qt_executable(deform
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/deform"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/deform"
+ SOURCES
+ main.cpp
+ pathdeform.cpp pathdeform.h
+ LIBRARIES # special case
+ painting_shared
+)
+
+# Resources:
+add_qt_resource(deform "deform" PREFIX "/res/deform" FILES
+ pathdeform.cpp
+ pathdeform.html)