summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/pathstroke/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/pathstroke/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/pathstroke/CMakeLists.txt35
1 files changed, 24 insertions, 11 deletions
diff --git a/examples/widgets/painting/pathstroke/CMakeLists.txt b/examples/widgets/painting/pathstroke/CMakeLists.txt
index 22a6635164..17de61fede 100644
--- a/examples/widgets/painting/pathstroke/CMakeLists.txt
+++ b/examples/widgets/painting/pathstroke/CMakeLists.txt
@@ -20,9 +20,12 @@ find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
qt_add_executable(pathstroke
- ../shared/arthurstyle.cpp ../shared/arthurstyle.h
- ../shared/arthurwidgets.cpp ../shared/arthurwidgets.h
- ../shared/hoverpoints.cpp ../shared/hoverpoints.h
+ # special case begin
+ # remove files from ../shared
+ #../shared/arthurstyle.cpp ../shared/arthurstyle.h
+ #../shared/arthurwidgets.cpp ../shared/arthurwidgets.h
+ #../shared/hoverpoints.cpp ../shared/hoverpoints.h
+ # special case end
main.cpp
pathstroke.cpp pathstroke.h
)
@@ -34,10 +37,17 @@ target_include_directories(pathstroke PUBLIC
../shared
)
+# special case begin
+if(NOT TARGET painting_shared::painting_shared)
+ add_subdirectory(../shared painting_shared)
+endif()
+# special case end
+
target_link_libraries(pathstroke PUBLIC
Qt::Core
Qt::Gui
Qt::Widgets
+ painting_shared::painting_shared # special case
)
@@ -205,15 +215,18 @@ qt6_add_resources(pathstroke "pathstroke"
${pathstroke_resource_files}
)
-if(QT_FEATURE_opengl)
- target_sources(pathstroke PUBLIC
- ../shared/fbopaintdevice.cpp ../shared/fbopaintdevice.h
- )
+# special case begin
+# remove files from ../shared
+#if(QT_FEATURE_opengl)
+ #target_sources(affine PUBLIC
+ #../shared/fbopaintdevice.cpp ../shared/fbopaintdevice.h
+ #)
- target_link_libraries(pathstroke PUBLIC
- Qt::OpenGL
- )
-endif()
+ #target_link_libraries(affine PUBLIC
+ #Qt::OpenGL
+ #)
+#endif()
+# special case end
install(TARGETS pathstroke
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"