summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/pathstroke/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/pathstroke/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/pathstroke/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/widgets/painting/pathstroke/CMakeLists.txt b/examples/widgets/painting/pathstroke/CMakeLists.txt
new file mode 100644
index 0000000000..150a1baa83
--- /dev/null
+++ b/examples/widgets/painting/pathstroke/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from pathstroke.pro.
+
+#####################################################################
+## pathstroke Binary:
+#####################################################################
+
+add_qt_executable(pathstroke
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/pathstroke"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/pathstroke"
+ SOURCES
+ main.cpp
+ pathstroke.cpp pathstroke.h
+ LIBRARIES # special case
+ painting_shared
+)
+
+# Resources:
+add_qt_resource(pathstroke "pathstroke" PREFIX "/res/pathstroke" FILES
+ pathstroke.cpp
+ pathstroke.html)