summaryrefslogtreecommitdiffstats
path: root/examples/widgets/richtext/orderform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/richtext/orderform/CMakeLists.txt')
-rw-r--r--examples/widgets/richtext/orderform/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/examples/widgets/richtext/orderform/CMakeLists.txt b/examples/widgets/richtext/orderform/CMakeLists.txt
new file mode 100644
index 0000000000..5f12e98cdf
--- /dev/null
+++ b/examples/widgets/richtext/orderform/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from orderform.pro.
+
+#####################################################################
+## orderform Binary:
+#####################################################################
+
+add_qt_executable(orderform
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/richtext/orderform"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/richtext/orderform"
+ SOURCES
+ detailsdialog.cpp detailsdialog.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(orderform CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)