summaryrefslogtreecommitdiffstats
path: root/examples/widgets/scroller/graphicsview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/scroller/graphicsview/CMakeLists.txt')
-rw-r--r--examples/widgets/scroller/graphicsview/CMakeLists.txt34
1 files changed, 21 insertions, 13 deletions
diff --git a/examples/widgets/scroller/graphicsview/CMakeLists.txt b/examples/widgets/scroller/graphicsview/CMakeLists.txt
index 0f25d6b71c..5b36cfc9ae 100644
--- a/examples/widgets/scroller/graphicsview/CMakeLists.txt
+++ b/examples/widgets/scroller/graphicsview/CMakeLists.txt
@@ -1,18 +1,26 @@
# Generated from graphicsview.pro.
-#####################################################################
-## graphicsview Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(graphicsview LANGUAGES CXX)
-add_qt_executable(graphicsview
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/scroller/graphicsview"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/scroller/graphicsview"
- SOURCES
- main.cpp
- LIBRARIES
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(graphicsview WIN32 MACOSX_BUNDLE
+ main.cpp
+)
+target_link_libraries(graphicsview PUBLIC
+ Qt::Widgets
)
-#### Keys ignored in scope 1:.:graphicsview.pro:<NONE>:
-# TEMPLATE = "app"
+install(TARGETS graphicsview
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)