summaryrefslogtreecommitdiffstats
path: root/examples/widgets/statemachine/factorial/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/statemachine/factorial/CMakeLists.txt')
-rw-r--r--examples/widgets/statemachine/factorial/CMakeLists.txt36
1 files changed, 20 insertions, 16 deletions
diff --git a/examples/widgets/statemachine/factorial/CMakeLists.txt b/examples/widgets/statemachine/factorial/CMakeLists.txt
index e38995220e..e383225705 100644
--- a/examples/widgets/statemachine/factorial/CMakeLists.txt
+++ b/examples/widgets/statemachine/factorial/CMakeLists.txt
@@ -1,22 +1,26 @@
# Generated from factorial.pro.
-#####################################################################
-## factorial Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(factorial LANGUAGES CXX)
-add_qt_executable(factorial
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/statemachine/factorial"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/statemachine/factorial"
- SOURCES
- main.cpp
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-## Scopes:
-#####################################################################
+find_package(Qt5 COMPONENTS Core)
-#### Keys ignored in scope 2:.:factorial.pro:WIN32:
-# CONFIG = "console"
+add_executable(factorial
+ main.cpp
+)
+target_link_libraries(factorial PUBLIC
+ Qt::Core
+)
-#### Keys ignored in scope 3:.:factorial.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
+install(TARGETS factorial
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)