summaryrefslogtreecommitdiffstats
path: root/examples/widgets/statemachine/factorial/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/statemachine/factorial/CMakeLists.txt')
-rw-r--r--examples/widgets/statemachine/factorial/CMakeLists.txt31
1 files changed, 0 insertions, 31 deletions
diff --git a/examples/widgets/statemachine/factorial/CMakeLists.txt b/examples/widgets/statemachine/factorial/CMakeLists.txt
deleted file mode 100644
index 17904e3cd2..0000000000
--- a/examples/widgets/statemachine/factorial/CMakeLists.txt
+++ /dev/null
@@ -1,31 +0,0 @@
-# Generated from factorial.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(factorial LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/statemachine/factorial")
-
-find_package(Qt6 COMPONENTS Core)
-
-add_executable(factorial
- main.cpp
-)
-target_link_libraries(factorial PUBLIC
- Qt::Core
-)
-
-install(TARGETS factorial
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)