summaryrefslogtreecommitdiffstats
path: root/examples/widgets/statemachine/pingpong/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/statemachine/pingpong/CMakeLists.txt')
-rw-r--r--examples/widgets/statemachine/pingpong/CMakeLists.txt36
1 files changed, 20 insertions, 16 deletions
diff --git a/examples/widgets/statemachine/pingpong/CMakeLists.txt b/examples/widgets/statemachine/pingpong/CMakeLists.txt
index b911bd727f..e3745a280d 100644
--- a/examples/widgets/statemachine/pingpong/CMakeLists.txt
+++ b/examples/widgets/statemachine/pingpong/CMakeLists.txt
@@ -1,22 +1,26 @@
# Generated from pingpong.pro.
-#####################################################################
-## pingpong Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(pingpong LANGUAGES CXX)
-add_qt_executable(pingpong
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/statemachine/pingpong"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/statemachine/pingpong"
- SOURCES
- main.cpp
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-## Scopes:
-#####################################################################
+find_package(Qt5 COMPONENTS Core)
-#### Keys ignored in scope 2:.:pingpong.pro:WIN32:
-# CONFIG = "console"
+add_executable(pingpong
+ main.cpp
+)
+target_link_libraries(pingpong PUBLIC
+ Qt::Core
+)
-#### Keys ignored in scope 3:.:pingpong.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
+install(TARGETS pingpong
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)