summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/widgets/tools/CMakeLists.txt b/examples/widgets/tools/CMakeLists.txt
index 022f4a2b8f..72bc4cc44b 100644
--- a/examples/widgets/tools/CMakeLists.txt
+++ b/examples/widgets/tools/CMakeLists.txt
@@ -14,5 +14,9 @@ add_subdirectory(undoframework)
if(QT_FEATURE_library) # special case
add_subdirectory(echoplugin)
- add_subdirectory(plugandpaint) # special case
+ # special case begin
+ if(QT_FEATURE_inputdialog)
+ add_subdirectory(plugandpaint)
+ endif()
+ # special case end
endif()