summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/completer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/completer/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/completer/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/widgets/tools/completer/CMakeLists.txt b/examples/widgets/tools/completer/CMakeLists.txt
new file mode 100644
index 0000000000..b39b4f262d
--- /dev/null
+++ b/examples/widgets/tools/completer/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from completer.pro.
+
+#####################################################################
+## completer Binary:
+#####################################################################
+
+add_qt_executable(completer
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/completer"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/completer"
+ SOURCES
+ fsmodel.cpp fsmodel.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(completer "completer" PREFIX "/" FILES
+ resources/countries.txt
+ resources/wordlist.txt)
+