summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt b/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
index 4ddd0bc4d7..3814fb235d 100644
--- a/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
+++ b/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
@@ -24,6 +24,10 @@ qt_add_executable(echopluginwindow # special case: renamed target
echowindow.cpp echowindow.h
main.cpp
)
+set_target_properties(echopluginwindow PROPERTIES # special case
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(echopluginwindow PUBLIC # special case
Qt::Core
Qt::Gui