summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/echoplugin/plugin/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/plugin/CMakeLists.txt26
1 files changed, 7 insertions, 19 deletions
diff --git a/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt b/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
index 7250a7e0a6..78f5dcbe70 100644
--- a/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
+++ b/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
@@ -1,22 +1,10 @@
-# Generated from plugin.pro.
+# special case begin
-#####################################################################
-## qtLibraryTargetechoplugin Module:
-#####################################################################
-
-add_qt_plugin(echoplugin_plugin TYPE plugin # special case
- SOURCES
- echoplugin.cpp echoplugin.h
- INCLUDE_DIRECTORIES
- ../echowindow
- LIBRARIES
- Qt::Widgets
+add_library(echoplugin MODULE
+ echoplugin.cpp echoplugin.h
)
-#### Keys ignored in scope 1:.:plugin.pro:<NONE>:
-# CONFIG = "plugin" "install_ok"
-# DESTDIR = "../plugins"
-# EXAMPLE_FILES = "echoplugin.json"
-# INSTALLS = "target"
-# TEMPLATE = "lib"
-# target.path = "$$[QT_INSTALL_EXAMPLES]/widgets/tools/echoplugin/plugins"
+target_include_directories(echoplugin PUBLIC ../echowindow)
+target_link_libraries(echoplugin PUBLIC Qt::Widgets)
+
+# special case end