summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/echoplugin/plugin/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/plugin/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt b/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
deleted file mode 100644
index 7d63180a87..0000000000
--- a/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-qt_add_plugin(echoplugin
- CLASS_NAME EchoPlugin
-)
-
-target_sources(echoplugin PRIVATE
- echoplugin.cpp echoplugin.h
-)
-
-set_target_properties(echoplugin PROPERTIES
- LIBRARY_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/echowindow"
-)
-
-target_include_directories(echoplugin PUBLIC
- ../echowindow
-)
-
-target_link_libraries(echoplugin PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-install(TARGETS echoplugin
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)