summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/plugandpaint/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/examples/widgets/tools/plugandpaint/CMakeLists.txt b/examples/widgets/tools/plugandpaint/CMakeLists.txt
index 4e35d0d0c3..3c997faf21 100644
--- a/examples/widgets/tools/plugandpaint/CMakeLists.txt
+++ b/examples/widgets/tools/plugandpaint/CMakeLists.txt
@@ -1,7 +1,19 @@
# Generated from plugandpaint.pro.
+# special case skip regeneration
+cmake_minimum_required(VERSION 3.14)
+project(plugandpaint LANGUAGES CXX)
-if(NOT QT_FEATURE_inputdialog)
- return()
+find_package(Qt6 COMPONENTS Core Gui Widgets)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tools/plugandpaint")
+
add_subdirectory(plugins)
add_subdirectory(app)