summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/plugandpaint/app/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/app/CMakeLists.txt50
1 files changed, 27 insertions, 23 deletions
diff --git a/examples/widgets/tools/plugandpaint/app/CMakeLists.txt b/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
index e5bbbacec2..2e730791cc 100644
--- a/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
+++ b/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
@@ -1,29 +1,33 @@
# Generated from app.pro.
-#####################################################################
-## plugandpaint Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(plugandpaint LANGUAGES CXX)
-add_qt_executable(plugandpaint
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/plugandpaint"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/plugandpaint"
- SOURCES
- interfaces.h
- main.cpp
- mainwindow.cpp mainwindow.h
- paintarea.cpp paintarea.h
- plugindialog.cpp plugindialog.h
- LIBRARIES
- Qt::Widgets
- pnp_basictools # special case
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-#### Keys ignored in scope 1:.:app.pro:<NONE>:
-# CONFIG = "install_ok"
-# DESTDIR = ".."
+find_package(Qt5 COMPONENTS Widgets)
-## Scopes:
-#####################################################################
+add_executable(plugandpaint WIN32 MACOSX_BUNDLE
+ interfaces.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ paintarea.cpp paintarea.h
+ plugindialog.cpp plugindialog.h
+)
+target_link_libraries(plugandpaint PUBLIC
+ # Remove: L../plugins
+ Qt::Widgets
+ pnp_basictools # special case
+)
+target_link_libraries(plugandpaint PUBLIC pnp_basictools) # special case
-# special case: Remove the rest
+install(TARGETS plugandpaint
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)