summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/plugandpaint/app/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/app/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/examples/widgets/tools/plugandpaint/app/CMakeLists.txt b/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
new file mode 100644
index 0000000000..e5bbbacec2
--- /dev/null
+++ b/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from app.pro.
+
+#####################################################################
+## plugandpaint Binary:
+#####################################################################
+
+add_qt_executable(plugandpaint
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/plugandpaint"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/plugandpaint"
+ SOURCES
+ interfaces.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ paintarea.cpp paintarea.h
+ plugindialog.cpp plugindialog.h
+ LIBRARIES
+ Qt::Widgets
+ pnp_basictools # special case
+)
+
+#### Keys ignored in scope 1:.:app.pro:<NONE>:
+# CONFIG = "install_ok"
+# DESTDIR = ".."
+
+## Scopes:
+#####################################################################
+
+# special case: Remove the rest