summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt b/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
new file mode 100644
index 0000000000..a059d0deab
--- /dev/null
+++ b/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from basictools.pro.
+
+#####################################################################
+## qtLibraryTargetpnp_basictools Module:
+#####################################################################
+
+add_qt_plugin(pnp_basictools # special case
+ STATIC # special case
+ OUTPUT_DIRECTORY ../../plugins # special case
+ INSTALL_DIRECTORY ../../plugins # special case
+ ARCHIVE_INSTALL_DIRECTORY ../../plugins # special case
+ SOURCES
+ basictoolsplugin.cpp basictoolsplugin.h
+ INCLUDE_DIRECTORIES
+ ../../app
+ LIBRARIES
+ Qt::Widgets
+)
+
+# CONFIG = "plugin" "static" "install_ok"
+# DESTDIR = "../../plugins"
+# INSTALLS = "target"
+# TEMPLATE = "lib"
+# target.path = "$$[QT_INSTALL_EXAMPLES]/widgets/tools/plugandpaint/plugins"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:basictools.pro:APPLE_UIKIT:
+# CONFIG = "debug_and_release"