summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt30
1 files changed, 6 insertions, 24 deletions
diff --git a/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt b/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
index a0447c833e..31d6f5ef65 100644
--- a/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
+++ b/examples/widgets/tools/plugandpaint/plugins/extrafilters/CMakeLists.txt
@@ -1,27 +1,9 @@
-# Generated from extrafilters.pro.
+# special case begin
-#####################################################################
-## qtLibraryTargetpnp_extrafilters Module:
-#####################################################################
-
-add_qt_plugin(pnp_extrafilters_plugin TYPE plugin # special case
- SOURCES
- extrafiltersplugin.cpp extrafiltersplugin.h
- INCLUDE_DIRECTORIES
- ../../app
- LIBRARIES
- Qt::Widgets
+add_library(pnp_extrafilters_plugin MODULE
+ extrafiltersplugin.cpp extrafiltersplugin.h
)
+target_include_directories(pnp_extrafilters_plugin PRIVATE ../../app)
+target_link_libraries(pnp_extrafilters_plugin PRIVATE Qt::Widgets)
-#### Keys ignored in scope 1:.:extrafilters.pro:<NONE>:
-# CONFIG = "plugin" "install_ok"
-# DESTDIR = "../../plugins"
-# INSTALLS = "target"
-# TEMPLATE = "lib"
-# target.path = "$$[QT_INSTALL_EXAMPLES]/widgets/tools/plugandpaint/plugins"
-
-## Scopes:
-#####################################################################
-
-#### Keys ignored in scope 2:.:extrafilters.pro:APPLE_UIKIT:
-# CONFIG = "debug_and_release"
+# special case end