summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/regexp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/regexp/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/regexp/CMakeLists.txt35
1 files changed, 23 insertions, 12 deletions
diff --git a/examples/widgets/tools/regexp/CMakeLists.txt b/examples/widgets/tools/regexp/CMakeLists.txt
index da729f5f5b..026e72673a 100644
--- a/examples/widgets/tools/regexp/CMakeLists.txt
+++ b/examples/widgets/tools/regexp/CMakeLists.txt
@@ -1,16 +1,27 @@
# Generated from regexp.pro.
-#####################################################################
-## regexp Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(regexp LANGUAGES CXX)
-add_qt_executable(regexp
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/regexp"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/regexp"
- SOURCES
- main.cpp
- regexpdialog.cpp regexpdialog.h
- LIBRARIES
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(regexp WIN32 MACOSX_BUNDLE
+ main.cpp
+ regexpdialog.cpp regexpdialog.h
+)
+target_link_libraries(regexp PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS regexp
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)