summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/undo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/undo/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/undo/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/examples/widgets/tools/undo/CMakeLists.txt b/examples/widgets/tools/undo/CMakeLists.txt
new file mode 100644
index 0000000000..751026bd62
--- /dev/null
+++ b/examples/widgets/tools/undo/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from undo.pro.
+
+#####################################################################
+## undo Binary:
+#####################################################################
+
+add_qt_executable(undo
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/undo"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/undo"
+ SOURCES
+ commands.cpp commands.h
+ document.cpp document.h
+ main.cpp
+ mainwindow.cpp mainwindow.h mainwindow.ui
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(undo "undo" PREFIX "/" FILES
+ icons/background.png
+ icons/blue.png
+ icons/circle.png
+ icons/exit.png
+ icons/fileclose.png
+ icons/filenew.png
+ icons/fileopen.png
+ icons/filesave.png
+ icons/green.png
+ icons/ok.png
+ icons/rectangle.png
+ icons/red.png
+ icons/redo.png
+ icons/remove.png
+ icons/triangle.png
+ icons/undo.png)
+
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:undo.pro:build_all AND NOT build_pass:
+# CONFIG = "-build_all" "release"