summaryrefslogtreecommitdiffstats
path: root/examples/widgets/touch/fingerpaint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/touch/fingerpaint/CMakeLists.txt')
-rw-r--r--examples/widgets/touch/fingerpaint/CMakeLists.txt53
1 files changed, 0 insertions, 53 deletions
diff --git a/examples/widgets/touch/fingerpaint/CMakeLists.txt b/examples/widgets/touch/fingerpaint/CMakeLists.txt
deleted file mode 100644
index 12e96173cf..0000000000
--- a/examples/widgets/touch/fingerpaint/CMakeLists.txt
+++ /dev/null
@@ -1,53 +0,0 @@
-# Generated from fingerpaint.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(fingerpaint LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/touch/fingerpaint")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS PrintSupport) # special case
-
-qt_add_executable(fingerpaint
- main.cpp
- mainwindow.cpp mainwindow.h
- scribblearea.cpp scribblearea.h
-)
-set_target_properties(fingerpaint PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(fingerpaint PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-# special case begin
-if (TARGET Qt::PrintSupport)
- target_link_libraries(fingerpaint PUBLIC Qt::PrintSupport)
-endif()
-# special case end
-
-if(TARGET Qt::PrintSupport)
- target_link_libraries(fingerpaint PUBLIC
- Qt::PrintSupport
- )
-endif()
-
-install(TARGETS fingerpaint
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)