summaryrefslogtreecommitdiffstats
path: root/examples/widgets/touch/fingerpaint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/touch/fingerpaint/CMakeLists.txt')
-rw-r--r--examples/widgets/touch/fingerpaint/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/examples/widgets/touch/fingerpaint/CMakeLists.txt b/examples/widgets/touch/fingerpaint/CMakeLists.txt
new file mode 100644
index 0000000000..82ec8cd91e
--- /dev/null
+++ b/examples/widgets/touch/fingerpaint/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from fingerpaint.pro.
+
+#####################################################################
+## fingerpaint Binary:
+#####################################################################
+
+add_qt_executable(fingerpaint
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/touch/fingerpaint"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/touch/fingerpaint"
+ SOURCES
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ scribblearea.cpp scribblearea.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(fingerpaint CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)