summaryrefslogtreecommitdiffstats
path: root/examples/widgets/touch/fingerpaint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/touch/fingerpaint/CMakeLists.txt')
-rw-r--r--examples/widgets/touch/fingerpaint/CMakeLists.txt47
1 files changed, 28 insertions, 19 deletions
diff --git a/examples/widgets/touch/fingerpaint/CMakeLists.txt b/examples/widgets/touch/fingerpaint/CMakeLists.txt
index 82ec8cd91e..a419a614be 100644
--- a/examples/widgets/touch/fingerpaint/CMakeLists.txt
+++ b/examples/widgets/touch/fingerpaint/CMakeLists.txt
@@ -1,25 +1,34 @@
# Generated from fingerpaint.pro.
-#####################################################################
-## fingerpaint Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(fingerpaint LANGUAGES CXX)
-add_qt_executable(fingerpaint
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/touch/fingerpaint"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/touch/fingerpaint"
- SOURCES
- main.cpp
- mainwindow.cpp mainwindow.h
- scribblearea.cpp scribblearea.h
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-## Scopes:
-#####################################################################
+find_package(Qt5 COMPONENTS Widgets)
+find_package(Qt5 COMPONENTS PrintSupport) # special case
+
+add_executable(fingerpaint WIN32 MACOSX_BUNDLE
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ scribblearea.cpp scribblearea.h
+)
+target_link_libraries(fingerpaint PUBLIC
+ Qt::Widgets
+)
+# special case begin
+if (TARGET Qt::PrintSupport)
+ target_link_libraries(fingerpaint PUBLIC Qt::PrintSupport)
+endif()
+# special case end
-extend_target(fingerpaint CONDITION TARGET Qt::PrintSupport
- LIBRARIES
- Qt::PrintSupport
+install(TARGETS fingerpaint
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)