summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt36
1 files changed, 22 insertions, 14 deletions
diff --git a/examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt b/examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt
index 1edda802f9..82e1b4dbab 100644
--- a/examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt
+++ b/examples/widgets/tutorials/modelview/1_readonly/CMakeLists.txt
@@ -1,19 +1,27 @@
# Generated from 1_readonly.pro.
-#####################################################################
-## mv_readonly Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(mv_readonly LANGUAGES CXX)
-add_qt_executable(mv_readonly
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tutorials/modelview/1_readonly"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tutorials/modelview/1_readonly"
- SOURCES
- main.cpp
- mymodel.cpp mymodel.h
- LIBRARIES
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(mv_readonly WIN32 MACOSX_BUNDLE
+ main.cpp
+ mymodel.cpp mymodel.h
+)
+target_link_libraries(mv_readonly PUBLIC
+ Qt::Widgets
)
-#### Keys ignored in scope 1:.:1_readonly.pro:<NONE>:
-# TEMPLATE = "app"
+install(TARGETS mv_readonly
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)