summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/notepad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tutorials/notepad/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/notepad/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/widgets/tutorials/notepad/CMakeLists.txt b/examples/widgets/tutorials/notepad/CMakeLists.txt
index 9dcf98fe4c..d34d3ca846 100644
--- a/examples/widgets/tutorials/notepad/CMakeLists.txt
+++ b/examples/widgets/tutorials/notepad/CMakeLists.txt
@@ -11,8 +11,10 @@ add_qt_executable(notepad
SOURCES
main.cpp
notepad.cpp notepad.h notepad.ui
+ ENABLE_AUTOGEN_TOOLS
+ uic
LIBRARIES # special case
- Qt::Widgets
+ Qt::Widgets # special case
)
# Resources:
@@ -37,13 +39,13 @@ add_qt_resource(notepad "notepad" PREFIX "/" FILES
images/underline.png)
-#### Keys ignored in scope 1:.:notepad.pro:<NONE>:
+#### Keys ignored in scope 1:.:.:notepad.pro:<TRUE>:
# TEMPLATE = "app"
## Scopes:
#####################################################################
extend_target(notepad CONDITION TARGET Qt::PrintSupport
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::PrintSupport
)