summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/notepad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tutorials/notepad/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/notepad/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/examples/widgets/tutorials/notepad/CMakeLists.txt b/examples/widgets/tutorials/notepad/CMakeLists.txt
new file mode 100644
index 0000000000..9dcf98fe4c
--- /dev/null
+++ b/examples/widgets/tutorials/notepad/CMakeLists.txt
@@ -0,0 +1,49 @@
+# Generated from notepad.pro.
+
+#####################################################################
+## notepad Binary:
+#####################################################################
+
+add_qt_executable(notepad
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tutorials/notepad"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tutorials/notepad"
+ SOURCES
+ main.cpp
+ notepad.cpp notepad.h notepad.ui
+ LIBRARIES # special case
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(notepad "notepad" PREFIX "/" FILES
+ images/bold.png
+ images/copy.png
+ images/create.png
+ images/cut.png
+ images/edit_redo.png
+ images/edit_undo.png
+ images/exit.png
+ images/font.png
+ images/info.png
+ images/italic.png
+ images/new.png
+ images/open.png
+ images/paste.png
+ images/pencil.png
+ images/print.png
+ images/save.png
+ images/save_as.png
+ images/underline.png)
+
+
+#### Keys ignored in scope 1:.:notepad.pro:<NONE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+extend_target(notepad CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)