summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/notepad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tutorials/notepad/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/notepad/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/examples/widgets/tutorials/notepad/CMakeLists.txt b/examples/widgets/tutorials/notepad/CMakeLists.txt
index a334176b9a..b2a5fae402 100644
--- a/examples/widgets/tutorials/notepad/CMakeLists.txt
+++ b/examples/widgets/tutorials/notepad/CMakeLists.txt
@@ -33,6 +33,10 @@ target_link_libraries(notepad PUBLIC
Qt6::Widgets
)
+if(TARGET Qt6::PrintSupport)
+ target_link_libraries(notepad PUBLIC Qt6::PrintSupport)
+endif()
+
# Resources:
set(notepad_resource_files
"images/bold.png"
@@ -62,12 +66,6 @@ qt_add_resources(notepad "notepad"
${notepad_resource_files}
)
-if(TARGET Qt6::PrintSupport)
- target_link_libraries(notepad PUBLIC
- Qt6::PrintSupport
- )
-endif()
-
install(TARGETS notepad
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"