summaryrefslogtreecommitdiffstats
path: root/examples/widgets/widgets/imageviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/widgets/imageviewer/CMakeLists.txt')
-rw-r--r--examples/widgets/widgets/imageviewer/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/examples/widgets/widgets/imageviewer/CMakeLists.txt b/examples/widgets/widgets/imageviewer/CMakeLists.txt
index 650a467108..96b782b0cd 100644
--- a/examples/widgets/widgets/imageviewer/CMakeLists.txt
+++ b/examples/widgets/widgets/imageviewer/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from imageviewer.pro.
-
cmake_minimum_required(VERSION 3.16)
project(imageviewer LANGUAGES CXX)
@@ -33,11 +31,10 @@ target_link_libraries(imageviewer PUBLIC
Qt::Gui
Qt::Widgets
)
-# special case begin
+
if (TARGET Qt::PrintSupport)
target_link_libraries(imageviewer PUBLIC Qt::PrintSupport)
endif()
-# special case end
if(TARGET Qt::PrintSupport)
target_link_libraries(imageviewer PUBLIC