summaryrefslogtreecommitdiffstats
path: root/examples/widgets/widgets/imageviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/widgets/imageviewer/CMakeLists.txt')
-rw-r--r--examples/widgets/widgets/imageviewer/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/examples/widgets/widgets/imageviewer/CMakeLists.txt b/examples/widgets/widgets/imageviewer/CMakeLists.txt
deleted file mode 100644
index fefccbbd1b..0000000000
--- a/examples/widgets/widgets/imageviewer/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-# Generated from imageviewer.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(imageviewer LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(INSTALL_EXAMPLEDIR "examples/widgets/widgets/imageviewer")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS PrintSupport) # special case
-
-add_qt_gui_executable(imageviewer
- imageviewer.cpp imageviewer.h
- main.cpp
-)
-target_link_libraries(imageviewer PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-# special case begin
-if (TARGET Qt::PrintSupport)
- target_link_libraries(imageviewer PUBLIC Qt::PrintSupport)
-endif()
-# special case end
-
-if(TARGET Qt::PrintSupport)
- target_link_libraries(imageviewer PUBLIC
- Qt::PrintSupport
- )
-endif()
-
-install(TARGETS imageviewer
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)