summaryrefslogtreecommitdiffstats
path: root/examples/widgets/widgets/scribble/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/widgets/scribble/CMakeLists.txt')
-rw-r--r--examples/widgets/widgets/scribble/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/examples/widgets/widgets/scribble/CMakeLists.txt b/examples/widgets/widgets/scribble/CMakeLists.txt
new file mode 100644
index 0000000000..d9b2292336
--- /dev/null
+++ b/examples/widgets/widgets/scribble/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from scribble.pro.
+
+#####################################################################
+## scribble Binary:
+#####################################################################
+
+add_qt_executable(scribble
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/widgets/scribble"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/widgets/scribble"
+ SOURCES
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ scribblearea.cpp scribblearea.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(scribble CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)