summaryrefslogtreecommitdiffstats
path: root/examples/widgets/windowcontainer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/windowcontainer/CMakeLists.txt')
-rw-r--r--examples/widgets/windowcontainer/CMakeLists.txt40
1 files changed, 26 insertions, 14 deletions
diff --git a/examples/widgets/windowcontainer/CMakeLists.txt b/examples/widgets/windowcontainer/CMakeLists.txt
index 88dc37ea5e..f67a6515bd 100644
--- a/examples/widgets/windowcontainer/CMakeLists.txt
+++ b/examples/widgets/windowcontainer/CMakeLists.txt
@@ -1,18 +1,30 @@
# Generated from windowcontainer.pro.
-#####################################################################
-## windowcontainer Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(windowcontainer LANGUAGES CXX)
-add_qt_executable(windowcontainer
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/windowcontainer"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/windowcontainer"
- SOURCES
- ../../gui/openglwindow/openglwindow.cpp ../../gui/openglwindow/openglwindow.h
- windowcontainer.cpp
- INCLUDE_DIRECTORIES
- ../../gui/openglwindow
- LIBRARIES
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(windowcontainer WIN32 MACOSX_BUNDLE
+ ../../gui/openglwindow/openglwindow.cpp ../../gui/openglwindow/openglwindow.h
+ windowcontainer.cpp
+)
+target_include_directories(windowcontainer PUBLIC
+ ../../gui/openglwindow
+)
+target_link_libraries(windowcontainer PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS windowcontainer
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)