summaryrefslogtreecommitdiffstats
path: root/examples/widgets/windowcontainer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/windowcontainer/CMakeLists.txt')
-rw-r--r--examples/widgets/windowcontainer/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/examples/widgets/windowcontainer/CMakeLists.txt b/examples/widgets/windowcontainer/CMakeLists.txt
deleted file mode 100644
index 5d299d06fb..0000000000
--- a/examples/widgets/windowcontainer/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(windowcontainer LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/windowcontainer")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui OpenGL Widgets)
-
-qt_add_executable(windowcontainer
- ../../opengl/openglwindow/openglwindow.cpp ../../opengl/openglwindow/openglwindow.h
- windowcontainer.cpp
-)
-
-set_target_properties(windowcontainer PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_include_directories(windowcontainer PUBLIC
- ../../opengl/openglwindow
-)
-
-target_link_libraries(windowcontainer PUBLIC
- Qt::Core
- Qt::Gui
- Qt::OpenGL
- Qt::Widgets
-)
-
-install(TARGETS windowcontainer
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)