summaryrefslogtreecommitdiffstats
path: root/examples/xml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/xml/CMakeLists.txt')
-rw-r--r--examples/xml/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/examples/xml/CMakeLists.txt b/examples/xml/CMakeLists.txt
index 9291c191e0..8e145b4ccb 100644
--- a/examples/xml/CMakeLists.txt
+++ b/examples/xml/CMakeLists.txt
@@ -2,12 +2,10 @@
add_subdirectory(htmlinfo)
add_subdirectory(xmlstreamlint)
-
if(TARGET Qt::Widgets)
add_subdirectory(dombookmarks)
add_subdirectory(streambookmarks)
-
- if(TARGET Qt::Network)
- add_subdirectory(rsslisting)
- endif()
+endif()
+if(TARGET Qt::Network AND TARGET Qt::Widgets)
+ add_subdirectory(rsslisting)
endif()