summaryrefslogtreecommitdiffstats
path: root/qmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qmake/CMakeLists.txt')
-rw-r--r--qmake/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/qmake/CMakeLists.txt b/qmake/CMakeLists.txt
index 49d622a5fe..a1e7625650 100644
--- a/qmake/CMakeLists.txt
+++ b/qmake/CMakeLists.txt
@@ -1,7 +1,12 @@
# Generated from qmake.pro.
-# special case:
-install(DIRECTORY "${PROJECT_SOURCE_DIR}/mkspecs" DESTINATION ${INSTALL_DATADIR})
+# special case begin
+set(path_component "${INSTALL_DATADIR}")
+qt_path_join(mkspecs_install_dir ${QT_INSTALL_DIR} ${path_component})
+
+qt_copy_or_install(DIRECTORY "${PROJECT_SOURCE_DIR}/mkspecs"
+ DESTINATION ${mkspecs_install_dir})
+# special case end
find_library(FWApplicationServices ApplicationServices) # special case
find_library(FWCoreServices CoreServices) # special case