summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/CMakeLists.txt')
-rw-r--r--src/3rdparty/CMakeLists.txt20
1 files changed, 18 insertions, 2 deletions
diff --git a/src/3rdparty/CMakeLists.txt b/src/3rdparty/CMakeLists.txt
index 79ff5cd93c..f9a6e7c68b 100644
--- a/src/3rdparty/CMakeLists.txt
+++ b/src/3rdparty/CMakeLists.txt
@@ -1,8 +1,24 @@
+# special case skip regeneration
+# The file is maintained manually
add_subdirectory(harfbuzz)
add_subdirectory(double-conversion)
-#special case begin
+if(QT_FEATURE_png AND NOT QT_FEATURE_system_png)
+ add_subdirectory(libpng)
+endif()
+
+if(QT_FEATURE_freetype AND NOT QT_FEATURE_system_freetype)
+ add_subdirectory(freetype)
+endif()
+
+if(QT_FEATURE_harfbuzz AND NOT QT_FEATURE_system_harfbuzz)
+ add_subdirectory(harfbuzz-ng)
+endif()
+
+if(QT_FEATURE_regularexpression AND NOT QT_FEATURE_system_pcre2)
+ add_subdirectory(pcre2)
+endif()
+
if (ANDROID)
add_subdirectory(gradle)
endif()
-#special case end