summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/CMakeLists.txt')
-rw-r--r--src/3rdparty/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/src/3rdparty/CMakeLists.txt b/src/3rdparty/CMakeLists.txt
index 56b81bb7af..493f6bddff 100644
--- a/src/3rdparty/CMakeLists.txt
+++ b/src/3rdparty/CMakeLists.txt
@@ -1,11 +1,13 @@
-# special case skip regeneration
-# The file is maintained manually
-
if(QT_FEATURE_gui AND QT_FEATURE_png AND NOT QT_FEATURE_system_png)
add_subdirectory(libpng)
endif()
qt_install_3rdparty_library_wrap_config_extra_file(BundledLibpng)
+if(QT_FEATURE_gui AND QT_FEATURE_jpeg AND NOT QT_FEATURE_system_jpeg)
+ add_subdirectory(libjpeg)
+endif()
+qt_install_3rdparty_library_wrap_config_extra_file(BundledLibjpeg)
+
if(QT_FEATURE_gui AND QT_FEATURE_freetype AND NOT QT_FEATURE_system_freetype)
add_subdirectory(freetype)
endif()
@@ -16,11 +18,6 @@ if(QT_FEATURE_gui AND QT_FEATURE_harfbuzz AND NOT QT_FEATURE_system_harfbuzz)
endif()
qt_install_3rdparty_library_wrap_config_extra_file(BundledHarfbuzz)
-if(QT_FEATURE_regularexpression AND NOT QT_FEATURE_system_pcre2)
- add_subdirectory(pcre2)
-endif()
-qt_install_3rdparty_library_wrap_config_extra_file(BundledPcre2)
-
if (ANDROID)
add_subdirectory(gradle)
endif()