summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/pcre2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/pcre2/CMakeLists.txt')
-rw-r--r--src/3rdparty/pcre2/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/src/3rdparty/pcre2/CMakeLists.txt b/src/3rdparty/pcre2/CMakeLists.txt
index f44d4bbd79..22b90a57e1 100644
--- a/src/3rdparty/pcre2/CMakeLists.txt
+++ b/src/3rdparty/pcre2/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from pcre2.pro.
-
#####################################################################
## BundledPcre2 Generic Library:
#####################################################################
@@ -7,11 +5,13 @@
qt_internal_add_3rdparty_library(BundledPcre2
QMAKE_LIB_NAME pcre2
STATIC
+ SKIP_AUTOMOC
SOURCES
src/config.h
src/pcre2.h
src/pcre2_auto_possess.c
src/pcre2_chartables.c
+ src/pcre2_chkdint.c
src/pcre2_compile.c
src/pcre2_config.c
src/pcre2_context.c
@@ -76,9 +76,4 @@ qt_internal_extend_target(BundledPcre2 CONDITION WIN32
PCRE2_STATIC
)
-#### Keys ignored in scope 8:.:.:pcre2.pri:QT_FEATURE_intelcet:
-# QMAKE_CFLAGS = "$$QMAKE_CFLAGS_SHSTK"
-
-# special case begin
qt_internal_apply_intel_cet(BundledPcre2 PRIVATE)
-# special case end