summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 0702c32170..a4890f9bc9 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -249,7 +249,6 @@ qt_add_module(Core
../3rdparty/tinycbor/src
LIBRARIES
Qt::GlobalConfigPrivate # special case
- Threads::Threads # special case
PRECOMPILED_HEADER
"global/qt_pch.h"
NO_PCH_SOURCES
@@ -276,6 +275,13 @@ endif()
qt_generate_qconfig_cpp()
+# Handle qtConfig(thread): CONFIG += thread like in qt.prf.
+# Aka if the feature is enabled, publically link against the threading library.
+# This also ensures the link flag is in the .prl file.
+if(QT_FEATURE_thread)
+ target_link_libraries(Platform INTERFACE Threads::Threads)
+endif()
+
# Handle QObject: Automoc does not work for this as it would
# require to spill internals into users:
qt_add_module(Core_qobject STATIC