summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt40
1 files changed, 23 insertions, 17 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 783346578b..4f53ab02f0 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -118,6 +118,9 @@ qt_add_module(Core
kernel/qobjectdefs.h
kernel/qobjectdefs_impl.h
kernel/qpointer.cpp kernel/qpointer.h
+ kernel/qproperty.cpp kernel/qproperty.h kernel/qproperty_p.h
+ kernel/qpropertybinding.cpp kernel/qpropertybinding_p.h
+ kernel/qpropertyprivate.h
kernel/qsharedmemory.cpp kernel/qsharedmemory.h kernel/qsharedmemory_p.h
kernel/qsignalmapper.cpp kernel/qsignalmapper.h
kernel/qsocketnotifier.cpp kernel/qsocketnotifier.h
@@ -508,7 +511,7 @@ qt_extend_target(Core CONDITION APPLE
${FWFoundation}
)
-qt_extend_target(Core CONDITION APPLE_OSX
+qt_extend_target(Core CONDITION MACOS
LIBRARIES
${FWAppKit}
${FWApplicationServices}
@@ -761,7 +764,7 @@ qt_extend_target(Core CONDITION QT_FEATURE_easingcurve
tools/qtimeline.cpp tools/qtimeline.h
)
-qt_extend_target(Core CONDITION UNIX AND NOT HAIKU AND NOT INTEGRITY AND NOT VXWORKS AND NOT WASM AND (NOT APPLE_OSX OR NOT ICC)
+qt_extend_target(Core CONDITION UNIX AND NOT HAIKU AND NOT INTEGRITY AND NOT VXWORKS AND NOT WASM AND (NOT ICC OR NOT MACOS)
LIBRARIES
m
)
@@ -795,12 +798,12 @@ qt_extend_target(Core CONDITION WIN32 AND NOT QT_FEATURE_icu
text/qcollator_win.cpp
)
-qt_extend_target(Core CONDITION APPLE_OSX AND NOT QT_FEATURE_icu
+qt_extend_target(Core CONDITION MACOS AND NOT QT_FEATURE_icu
SOURCES
text/qcollator_macx.cpp
)
-qt_extend_target(Core CONDITION UNIX AND NOT APPLE_OSX AND NOT QT_FEATURE_icu
+qt_extend_target(Core CONDITION UNIX AND NOT MACOS AND NOT QT_FEATURE_icu
SOURCES
text/qcollator_posix.cpp
)
@@ -887,17 +890,17 @@ qt_extend_target(Core CONDITION QT_FEATURE_filesystemwatcher AND WIN32
io/qfilesystemwatcher_win.cpp io/qfilesystemwatcher_win_p.h
)
-qt_extend_target(Core CONDITION APPLE_OSX AND QT_FEATURE_filesystemwatcher
+qt_extend_target(Core CONDITION MACOS AND QT_FEATURE_filesystemwatcher
SOURCES
io/qfilesystemwatcher_fsevents.mm io/qfilesystemwatcher_fsevents_p.h
)
-qt_extend_target(Core CONDITION QT_FEATURE_filesystemwatcher AND QT_FEATURE_inotify AND UNIX AND NOT APPLE_OSX
+qt_extend_target(Core CONDITION QT_FEATURE_filesystemwatcher AND QT_FEATURE_inotify AND UNIX AND NOT MACOS
SOURCES
io/qfilesystemwatcher_inotify.cpp io/qfilesystemwatcher_inotify_p.h
)
-qt_extend_target(Core CONDITION QT_FEATURE_filesystemwatcher AND UNIX AND NOT APPLE_OSX AND NOT QT_FEATURE_inotify AND (APPLE OR FREEBSD OR NETBSD OR OPENBSD)
+qt_extend_target(Core CONDITION QT_FEATURE_filesystemwatcher AND UNIX AND NOT MACOS AND NOT QT_FEATURE_inotify AND (APPLE OR FREEBSD OR NETBSD OR OPENBSD)
SOURCES
io/qfilesystemwatcher_kqueue.cpp io/qfilesystemwatcher_kqueue_p.h
)
@@ -969,7 +972,7 @@ qt_extend_target(Core CONDITION APPLE AND QT_FEATURE_processenvironment
io/qprocess_darwin.mm
)
-qt_extend_target(Core CONDITION APPLE AND NOT APPLE_OSX
+qt_extend_target(Core CONDITION APPLE AND NOT MACOS
PUBLIC_LIBRARIES
${FWMobileCoreServices}
)
@@ -1049,12 +1052,12 @@ qt_extend_target(Core CONDITION QT_FEATURE_dlopen AND QT_FEATURE_library
${CMAKE_DL_LIBS}
)
-qt_extend_target(Core CONDITION APPLE AND (APPLE_IOS OR APPLE_TVOS)
+qt_extend_target(Core CONDITION APPLE AND (IOS OR TVOS)
LIBRARIES
${FWUIKit}
)
-qt_extend_target(Core CONDITION APPLE_WATCHOS
+qt_extend_target(Core CONDITION WATCHOS
LIBRARIES
${FWWatchKit}
)
@@ -1205,20 +1208,23 @@ qt_extend_target(Core CONDITION QT_FEATURE_mimetype
# mimedb.output = "$$outpath/qmimeprovider_database.cpp"
# mimedb.variable_out = "INCLUDED_SOURCES"
-#### Keys ignored in scope 200:.:mimetypes:mimetypes/mimetypes.pri:(CMAKE_BUILD_TYPE STREQUAL Debug):
-# outpath = ".rcc/debug"
+#### Keys ignored in scope 199:.:mimetypes:mimetypes/mimetypes.pri:ANDROID:
+# outpath = "$$outpath/$${QT_ARCH}"
-#### Keys ignored in scope 201:.:mimetypes:mimetypes/mimetypes.pri:else:
-# outpath = ".rcc/release"
+#### Keys ignored in scope 201:.:mimetypes:mimetypes/mimetypes.pri:(CMAKE_BUILD_TYPE STREQUAL Debug):
+# outpath = "$$outpath/debug"
-#### Keys ignored in scope 202:.:mimetypes:mimetypes/mimetypes.pri:MAKEFILE_GENERATOR___equals___MSVC.NET OR MAKEFILE_GENERATOR___equals___MSBUILD OR QMAKE_SH_ISEMPTY:
+#### Keys ignored in scope 202:.:mimetypes:mimetypes/mimetypes.pri:else:
+# outpath = "$$outpath/release"
+
+#### Keys ignored in scope 203:.:mimetypes:mimetypes/mimetypes.pri:MAKEFILE_GENERATOR___equals___MSVC.NET OR MAKEFILE_GENERATOR___equals___MSBUILD OR QMAKE_SH_ISEMPTY:
# mimedb.commands = "cmd" "/c" "$$shell_path($$PWD/mime/generate.bat)"
# mimedb.depends = "$$PWD/mime/generate.bat" "$$PWD/mime/hexdump.ps1"
-#### Keys ignored in scope 203:.:mimetypes:mimetypes/mimetypes.pri:else:
+#### Keys ignored in scope 204:.:mimetypes:mimetypes/mimetypes.pri:else:
# mimedb.commands = "perl" "$${mimedb.depends}"
-#### Keys ignored in scope 204:.:mimetypes:mimetypes/mimetypes.pri:QT_FEATURE_zstd:
+#### Keys ignored in scope 205:.:mimetypes:mimetypes/mimetypes.pri:QT_FEATURE_zstd:
# mimedb.commands = "--zstd"
# Resources:
# special case begin