summaryrefslogtreecommitdiffstats
path: root/src/entrypoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/entrypoint/CMakeLists.txt')
-rw-r--r--src/entrypoint/CMakeLists.txt17
1 files changed, 10 insertions, 7 deletions
diff --git a/src/entrypoint/CMakeLists.txt b/src/entrypoint/CMakeLists.txt
index 1a145746ac..332aa8298b 100644
--- a/src/entrypoint/CMakeLists.txt
+++ b/src/entrypoint/CMakeLists.txt
@@ -20,6 +20,7 @@ qt_internal_add_module(EntryPoint
NO_ADDITIONAL_TARGET_INFO
)
+set(export_targets EntryPoint)
# We don't need any include paths or default module defines
set_target_properties(EntryPoint PROPERTIES
INTERFACE_INCLUDE_DIRECTORIES ""
@@ -38,6 +39,8 @@ if(using_entrypoint_library)
$<TARGET_PROPERTY:Qt::Core,INTERFACE_INCLUDE_DIRECTORIES>
)
+ list(APPEND export_targets EntryPointImplementation)
+
set_target_properties(EntryPointImplementation PROPERTIES
OUTPUT_NAME "${INSTALL_CMAKE_NAMESPACE}EntryPoint${QT_LIBINFIX}"
ARCHIVE_OUTPUT_DIRECTORY "${QT_BUILD_DIR}/${INSTALL_LIBDIR}"
@@ -103,13 +106,13 @@ QT.entrypoint_implementation.module_config = staticlib v2 internal_module
set(export_name "${INSTALL_CMAKE_NAMESPACE}EntryPointTargets")
qt_install(TARGETS EntryPointImplementation EXPORT ${export_name})
qt_generate_prl_file(EntryPointImplementation "${INSTALL_LIBDIR}")
-
- set(export_name_prefix "${INSTALL_CMAKE_NAMESPACE}EntryPoint")
- qt_path_join(config_install_dir ${QT_CONFIG_INSTALL_DIR} ${export_name_prefix})
- qt_internal_export_additional_targets_file(
- TARGETS EntryPoint EntryPointImplementation
- EXPORT_NAME_PREFIX ${export_name_prefix}
- CONFIG_INSTALL_DIR "${config_install_dir}")
endif()
+set(export_name_prefix "${INSTALL_CMAKE_NAMESPACE}EntryPoint")
+qt_path_join(config_install_dir ${QT_CONFIG_INSTALL_DIR} ${export_name_prefix})
+qt_internal_export_additional_targets_file(
+ TARGETS ${export_targets}
+ EXPORT_NAME_PREFIX ${export_name_prefix}
+ CONFIG_INSTALL_DIR "${config_install_dir}")
+
# special case end