summaryrefslogtreecommitdiffstats
path: root/src/entrypoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/entrypoint/CMakeLists.txt')
-rw-r--r--src/entrypoint/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/entrypoint/CMakeLists.txt b/src/entrypoint/CMakeLists.txt
new file mode 100644
index 0000000000..16c01540dd
--- /dev/null
+++ b/src/entrypoint/CMakeLists.txt
@@ -0,0 +1,33 @@
+# special case begin
+# special case skip regeneration
+if (NOT WIN32)
+ return()
+endif()
+
+qt_internal_add_module(EntryPoint
+ STATIC
+ NO_SYNC_QT
+ NO_MODULE_HEADERS
+ DEFINES
+ QT_NO_FOREACH
+ INCLUDE_DIRECTORIES
+ $<TARGET_PROPERTY:Qt::Core,INTERFACE_INCLUDE_DIRECTORIES>
+)
+
+if (MSVC)
+ # Store debug information inside the static lib
+ qt_internal_replace_compiler_flags(
+ "/Zi" "/Z7"
+ CONFIGS DEBUG RELWITHDEBINFO
+ IN_CURRENT_SCOPE)
+endif()
+
+qt_internal_extend_target(EntryPoint CONDITION WIN32
+ SOURCES qtentrypoint_win.cpp
+ LIBRARIES shell32
+)
+
+qt_internal_extend_target(EntryPoint CONDITION MINGW
+ DEFINES QT_NEEDS_QMAIN
+)
+# special case end