summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index aff73daeee..db6f463c0b 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -898,6 +898,14 @@ qt_extend_target(Gui CONDITION QT_FEATURE_systemtrayicon AND TARGET Qt::DBus AND
platform/unix/dbustray/qxdgnotificationproxy.cpp platform/unix/dbustray/qxdgnotificationproxy_p.h
)
+qt_extend_target(Gui CONDITION QT_FEATURE_xkbcommon AND UNIX
+ SOURCES
+ platform/unix/qxkbcommon.cpp platform/unix/qxkbcommon_p.h
+ platform/unix/qxkbcommon_3rdparty.cpp
+ PUBLIC_LIBRARIES
+ XKB::XKB
+)
+
qt_extend_target(Gui CONDITION IOS OR MACOS
SOURCES
rhi/qrhimetal.mm rhi/qrhimetal_p.h