summaryrefslogtreecommitdiffstats
path: root/src/opengl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/opengl/CMakeLists.txt')
-rw-r--r--src/opengl/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/opengl/CMakeLists.txt b/src/opengl/CMakeLists.txt
new file mode 100644
index 0000000000..18378a7564
--- /dev/null
+++ b/src/opengl/CMakeLists.txt
@@ -0,0 +1,56 @@
+# Generated from opengl.pro.
+
+#####################################################################
+## OpenGL Module:
+#####################################################################
+
+qt_add_module(OpenGL
+ SOURCES
+ qopengl2pexvertexarray.cpp qopengl2pexvertexarray_p.h
+ qopenglbuffer.cpp qopenglbuffer.h
+ qopenglcustomshaderstage.cpp qopenglcustomshaderstage_p.h
+ qopengldebug.cpp qopengldebug.h
+ qopenglengineshadermanager.cpp qopenglengineshadermanager_p.h
+ qopenglengineshadersource_p.h
+ qopenglframebufferobject.cpp qopenglframebufferobject.h qopenglframebufferobject_p.h
+ qopenglgradientcache.cpp qopenglgradientcache_p.h
+ qopenglpaintdevice.cpp qopenglpaintdevice.h qopenglpaintdevice_p.h
+ qopenglpaintengine.cpp qopenglpaintengine_p.h
+ qopenglpixeltransferoptions.cpp qopenglpixeltransferoptions.h
+ qopenglshadercache_p.h
+ qopenglshaderprogram.cpp qopenglshaderprogram.h
+ qopengltexture.cpp qopengltexture.h qopengltexture_p.h
+ qopengltextureblitter.cpp qopengltextureblitter.h
+ qopengltexturecache.cpp qopengltexturecache_p.h
+ qopengltextureglyphcache.cpp qopengltextureglyphcache_p.h
+ qopengltexturehelper.cpp qopengltexturehelper_p.h
+ qopengltextureuploader.cpp qopengltextureuploader_p.h
+ qopenglvertexarrayobject.cpp qopenglvertexarrayobject.h
+ qopenglwindow.cpp qopenglwindow.h
+ qtopenglglobal.h
+ DEFINES
+ QT_NO_FOREACH
+ QT_NO_USING_NAMESPACE
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ PRIVATE_MODULE_INTERFACE
+ Qt::CorePrivate
+ Qt::GuiPrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(OpenGL CONDITION NOT QT_FEATURE_opengles2
+ SOURCES
+ qopenglqueryhelper_p.h
+ qopengltimerquery.cpp qopengltimerquery.h
+)
+qt_add_docs(OpenGL
+ doc/qtopengl.qdocconf
+)
+