summaryrefslogtreecommitdiffstats
path: root/src/platformheaders/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/platformheaders/CMakeLists.txt')
-rw-r--r--src/platformheaders/CMakeLists.txt26
1 files changed, 20 insertions, 6 deletions
diff --git a/src/platformheaders/CMakeLists.txt b/src/platformheaders/CMakeLists.txt
index 820bbb71a5..63bb60576f 100644
--- a/src/platformheaders/CMakeLists.txt
+++ b/src/platformheaders/CMakeLists.txt
@@ -1,13 +1,27 @@
# Generated from platformheaders.pro.
-# special case begin
-
-# FIXME Add the rest of the stuff? I don't think any other stuff is needed?
-
-qt_add_module(PlatformHeaders HEADER_MODULE)
+#####################################################################
+## PlatformHeaders Module:
+#####################################################################
+qt_add_module(PlatformHeaders
+ HEADER_MODULE
+ # special case begin
+ # SOURCES
+ # cocoafunctions/qcocoawindowfunctions_p.h
+ # eglfsfunctions/qeglfsfunctions_p.h
+ # helper/qplatformheaderhelper_p.h
+ # linuxfbfunctions/qlinuxfbfunctions_p.h
+ # waylandfunctions/qwaylandwindowfunctions_p.h
+ # windowsfunctions/qwindowswindowfunctions_p.h
+ # xcbfunctions/qxcbscreenfunctions_p.h
+ # xcbfunctions/qxcbwindowfunctions_p.h
+ # special case end
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+)
qt_add_docs(PlatformHeaders
doc/qtplatformheaders.qdocconf
)
-# special case end