summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/devicediscovery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/platformsupport/devicediscovery/CMakeLists.txt')
-rw-r--r--src/platformsupport/devicediscovery/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/src/platformsupport/devicediscovery/CMakeLists.txt b/src/platformsupport/devicediscovery/CMakeLists.txt
index 6253a024c0..8ecabb4a1b 100644
--- a/src/platformsupport/devicediscovery/CMakeLists.txt
+++ b/src/platformsupport/devicediscovery/CMakeLists.txt
@@ -4,40 +4,37 @@
## DeviceDiscoverySupport Module:
#####################################################################
-add_qt_module(DeviceDiscoverySupport
+qt_add_module(DeviceDiscoverySupport
STATIC
INTERNAL_MODULE
SOURCES
qdevicediscovery_p.h
DEFINES
QT_NO_CAST_FROM_ASCII
- LIBRARIES
- Qt::CorePrivate
PUBLIC_LIBRARIES
- Qt::Core
+ Qt::CorePrivate
)
#### Keys ignored in scope 1:.:.:devicediscovery.pro:<TRUE>:
# MODULE = "devicediscovery_support"
# QT_FOR_CONFIG = "gui-private"
-# _LOADED = "qt_module"
## Scopes:
#####################################################################
-extend_target(DeviceDiscoverySupport CONDITION QT_FEATURE_libudev
+qt_extend_target(DeviceDiscoverySupport CONDITION QT_FEATURE_libudev
SOURCES
qdevicediscovery_udev.cpp qdevicediscovery_udev_p.h
LIBRARIES
PkgConfig::Libudev
)
-extend_target(DeviceDiscoverySupport CONDITION QT_FEATURE_evdev AND NOT QT_FEATURE_libudev
+qt_extend_target(DeviceDiscoverySupport CONDITION QT_FEATURE_evdev AND NOT QT_FEATURE_libudev
SOURCES
qdevicediscovery_static.cpp qdevicediscovery_static_p.h
)
-extend_target(DeviceDiscoverySupport CONDITION NOT QT_FEATURE_evdev AND NOT QT_FEATURE_libudev
+qt_extend_target(DeviceDiscoverySupport CONDITION NOT QT_FEATURE_evdev AND NOT QT_FEATURE_libudev
SOURCES
qdevicediscovery_dummy.cpp qdevicediscovery_dummy_p.h
)